안녕하세요~ 고객님, ipTIME 기술팀 입니다.
문의하신 내용에 답변 드리겠습니다.
서드파티 패키지의 종료(처리과정)에 관한 과정은 당사에서도 알기 어려우므로 도움을 드리지 못함에 양해 바라며,
당사에서 제공하는 entware 아이디의 권한은 root(최고관리자) 이므로 권한으로 인한 문제가 아닌, 다른원인을 찾아보셔야 할 것 같습니다.
감사합니다.
A5004 10.08.6 사용자 입니다. entware 활용중에 같은 문제가 반복적으로 발생하여, 펌웨어 오류가 아닌지 의심되어 글 남깁니다.
문제는 텔넷에서 서비스를 가동한 후, 중지시킬 때 발생합니다.
1. 펌웨어를 통한 entware 설치.
2. 텔넷 오픈
3. PC로 텔넷 접속
4. opkg install [app] 커맨드로 패키지 설치
5. /opt/etc/init.d/[app] start 커맨드로 서비스 오픈
6. /opt/etc/init.d/[app] stop 커맨드로 서비스 종료
6번 과정에서 정상종료가 되지 않고 종료도 되지 않는 서비스에 무한히 종료를 시도하고 실패하기를 반복하기 때문에 사실상 강제종료 말고는 답이 없는 상황이 나옵니다.
모든 패키지에서 다 문제가 발생하는것은 아닙니다. 웹서버를 구상하고 lighttpd를 설치해서 테스트해보다가 상기의 문제 발생으로, 또 다른 서버인 nginx 를 설치해서 이용해보았는데 문제가 없었습니다. 그래서 lighttpd 문제로 치부하고 있었는데, 다른 패키지도 설치해보면서 이용하다보니 꽤나 높은 확률로 문제가 발생합니다. php7-fpm도 같은 문제가 발생합니다.
추측컨데 권한 문제가 아닌가 싶습니다. 텔넷 접속시 공유기 관리자의 계정정보를 활용하도록 되어있는데 이 계정의 권한이 다소 빡빡하게 설정된것이 아닌지요?
[2019-02-18 14:01:32] |